Author Topic: Left blinker not working. BUZZING SOUND  (Read 108 times)

Offline Steviescumbag

  • Motobrick Curious
  • Posts: 11
Left blinker not working. BUZZING SOUND
« on: April 07, 2021, 09:11:14 PM »
Hey good friends,

The left
Blinker and brake lights on my 1992 k75rt has stopped working. When I press the left blinker I hear a buzzing sound coming from the electrical box.

Right signal works fine

Any advice would be greatly appreciated
  • Toronto, Canada
  • 1992 bmw K75 Rt

Offline The Mighty Gryphon

  • ^ Quintessential Motobricker
  • Posts: 5653
Re: Left blinker not working. BUZZING SOUND
« Reply #1 on: April 07, 2021, 11:56:50 PM »
Does your bike have hazard flashers?  How are they working?
  • In my garage in Marilla, NY
  • '94 K75RT Mystic Red, '91K100RS White/Blue, '89 K100RS Special edition White/Blue
Current:
'94 K75RT "Ilsa, She Wolf of the SS"
'91 K100RS "Moby Brick Too
'89 K100RS SE

Offline rbm

  • ^ Quintessential Motobricker
  • Posts: 2073
Re: Left blinker not working. BUZZING SOUND
« Reply #2 on: April 08, 2021, 12:13:25 AM »
Check the condition of Fuse 3. Is it intact  Have you made any changes recently to the signal circuitry, like install LEDs.
  • Regards, Robert
Toronto, Ontario

1987 K75 - Build Blog @http://k75retro.blogspot.ca/

Offline daveson

  • ^ SuperNatural Motobricker
  • Posts: 730
Re: Left blinker not working. BUZZING SOUND
« Reply #3 on: April 08, 2021, 02:19:25 AM »
Has the horn been working, and is it working at the moment? Has the triangular bulb warning light on the cluster been cancelling with the front and rear brake levers?
  • Victoria, Australia
  • Current;'85 K100RT~100,000km; four other bricks. Past; 1500 Vulcan, V Star 650, KLX 250(dirt bike) TT250(dirt bike)

Offline Steviescumbag

  • Motobrick Curious
  • Posts: 11
Re: Left blinker not working. BUZZING SOUND
« Reply #4 on: April 08, 2021, 04:39:25 PM »
Thanks for the feedback .

Maybe I missed a few key notes lol

I removed the taillight, removed the cluster, and cut the hazards switch. I plan on putting a new Speedo and led brake light

But again the right blinkers works. I’m confused why one would work and the other wouldn’t. Could it be because I have no speedo connected or the cut hazards switch?
  • Toronto, Canada
  • 1992 bmw K75 Rt

Offline rbm

  • ^ Quintessential Motobricker
  • Posts: 2073
Re: Left blinker not working. BUZZING SOUND
« Reply #5 on: April 08, 2021, 07:29:06 PM »
You're in Toronto.  PM me and maybe I can help.
  • Regards, Robert
Toronto, Ontario

1987 K75 - Build Blog @http://k75retro.blogspot.ca/

Offline Steviescumbag

  • Motobrick Curious
  • Posts: 11
Re: Left blinker not working. BUZZING SOUND
« Reply #6 on: April 08, 2021, 08:14:39 PM »
Yes I am Robert. Is there any other way we can discuss. For some reason I don’t have access to your profile so I can PM you.

I switched fuses that looked damaged.
  • Toronto, Canada
  • 1992 bmw K75 Rt

Online Laitch

  • Redline 7000
  • Forum Moderator
  • ^ Quintessential Motobricker
  • Posts: 8512
Re: Left blinker not working. BUZZING SOUND
« Reply #7 on: April 08, 2021, 10:05:58 PM »
I don’t have access to your profile so I can PM you.
There's an icon under his avatar next to his reply—and under your avatar, too—that looks like a speech bubble. Click on that to compose and send a personal message.
  • Along the Ridley in Vermont.
  • 1995 K75 80,000 miles
I wept because I had no radials until I met a man who had no splines.
https://tinyurl.com/RillRider

Offline daveson

  • ^ SuperNatural Motobricker
  • Posts: 730
Re: Left blinker not working. BUZZING SOUND
« Reply #8 on: April 09, 2021, 09:46:58 PM »
One thing the blinkers and brakes have in common is earth at the rear. The buzz could be the horn relay as the blinkers try to steal earth from that path. might be worth having a look up the back.
  • Victoria, Australia
  • Current;'85 K100RT~100,000km; four other bricks. Past; 1500 Vulcan, V Star 650, KLX 250(dirt bike) TT250(dirt bike)

Offline rbm

  • ^ Quintessential Motobricker
  • Posts: 2073
Re: Left blinker not working. BUZZING SOUND
« Reply #9 on: April 09, 2021, 10:16:04 PM »
I PMed you with my phone number.  Give me a call.  Might be a quick diagnosis and repair.
  • Regards, Robert
Toronto, Ontario

1987 K75 - Build Blog @http://k75retro.blogspot.ca/

Offline Steviescumbag

  • Motobrick Curious
  • Posts: 11
Re: Left blinker not working. BUZZING SOUND
« Reply #10 on: April 11, 2021, 01:48:30 PM »
The horn is working btw.
  • Toronto, Canada
  • 1992 bmw K75 Rt

Tags: