Author Topic: Hi all  (Read 150 times)

Offline LLL

  • Curious
  • Posts: 3
Hi all
« on: November 26, 2022, 03:28:06 PM »
Hi all,
Getting back into full sized motorcycles in the last couple of years.
The first couple have been horribly uncomfortable so having had a early k100rs in the past and knowing I fit at 6ft3in here I am.
Bought a modified for looks only scrambler a week ago test rode it etc... all good. Only to discover an electrical gremlin after trailering it home. It would start then eventually just stop and struggle to go again.
New battery, old one was down to 70cca... still doing it
Looked around online for the why... one post recommended cleaning the ignition switch.
Turned out to have black/ brown varnish looking gunk throughout the contact areas... cleaned/ sanded and now goes well.
  • Tauranga
  • 87 k100lt scrambler

Offline The Mighty Gryphon

  • Administrator
  • ^ Quintessential Motobricker
  • Posts: 6274
Re: Hi all
« Reply #1 on: November 26, 2022, 03:54:39 PM »
Welcome!  And Kudos for a troubleshooting job well done.
  • In my garage in Marilla, NY
  • '94 K75RT Mystic Red, '91K100RS White/Blue
Current:
'94 K75RT "Ilsa, She Wolf of the SS"
'91 K100RS16V "Moby Brick Too"

Past:
'92 K100RS16V "Moby Brick" (RIP, deceased in a vehicular assault)
'94 K75S Special Edition Dakar Yellow "Cheetos"
'89 K100RS Special Edition "Special Ed"

Offline Chaos

  • Administrator
  • ^ Quintessential Motobricker
  • Posts: 2901
  • Mars needs women!
Re: Hi all
« Reply #2 on: November 26, 2022, 10:06:59 PM »
Welcome back!   Electrical glitches and vacuum leaks, the nemeses of old K's. And my VW.
  • sw ohio
1987 K75S    VIN 0231
Original owner, Original litter
200,000 miles (plus or minus) and 5 paint jobs
2012 Ural 2WD sidecar (BMW's bastard step child)

Tags: