Author Topic: 1985 K100 RT That didn't run...does now with issues!  (Read 23380 times)

Offline The Mighty Gryphon

  • ^ Quintessential Motobricker
  • Posts: 3620
Re: 1985 K100 RT It doesn't run...
« Reply #50 on: January 29, 2017, 07:50:28 PM »
Good to hear the pump and fuel lines are ok.

Keep hitting the injectors with the 9v.  Even if you don't get any flow you are bumping the pintle and the crap built up around it.  With any luck you will eventually break it free.  As long as you just momentarily connect the power, there is no reason that you couldn't use 12v.  All you are looking for right now is an electrical "tap" on the pintle.  There is no reason to leave the power on.

Keep an eye on eBay.  There are a number of usable injectors from running bikes available for very reasonable prices there.   If you can't get yours to work this is a good source for replacements.
  • In my garage in Marilla, NY
  • '94 K75RT Mystic Red, '92K100RS White, '94 K75S Dakar Yellow
Current:
'94 K75RT "Ilsa, She Wolf of the SS"
'94 K75S "Cheetos"
'91 K100RS "Moby Brick Too

Offline The Mighty Gryphon

  • ^ Quintessential Motobricker
  • Posts: 3620
  • In my garage in Marilla, NY
  • '94 K75RT Mystic Red, '92K100RS White, '94 K75S Dakar Yellow
Current:
'94 K75RT "Ilsa, She Wolf of the SS"
'94 K75S "Cheetos"
'91 K100RS "Moby Brick Too

Offline jakgieger

  • itinerant farmer
  • ^ SuperNatural Motobricker
  • Posts: 535
Re: 1985 K100 RT It doesn't run...
« Reply #52 on: January 29, 2017, 09:18:20 PM »
If your local injector guy is competent, he can rework them.  Luckily here in the midwest USA, we have a lot of competent injection shops (diesel gearheads).  This is not rocket science :bmwsmile .  You may have to wait for him to order kits.  My oddball bosch injectors (tractor) took 2 weeks to get the appropriate kit.   
  • Kansas USA
  • 1989 K100rs se
"What we've got here is failure, to communicate.  Some men, you just cain't reach.  So you get what we had here last week.  Which is the way he wants it...Well, he gets it.  I don't like it any more than you men do."

Offline jakgieger

  • itinerant farmer
  • ^ SuperNatural Motobricker
  • Posts: 535
Re: 1985 K100 RT It doesn't run...
« Reply #53 on: January 29, 2017, 09:37:10 PM »
This is an option as well.  I have done this to my bike and am pleased so far (it's fast enough to scare me :hehehe ...but then again, I scare easily :hehehe .
  • Kansas USA
  • 1989 K100rs se
"What we've got here is failure, to communicate.  Some men, you just cain't reach.  So you get what we had here last week.  Which is the way he wants it...Well, he gets it.  I don't like it any more than you men do."

Offline Supershooter

  • ^ Proficient Motobricker
  • Posts: 161
Re: 1985 K100 RT It doesn't run...
« Reply #54 on: January 29, 2017, 10:44:13 PM »
Jack, other than new injectors did you have to do anything else to make it function correctly? I love speed and power. My other Bagger is a HD that makes a 100 hp and 110 tq.


Supershooter
  • Liberty Township, O'brien County, Iowa
  • 85 K100 RT

Offline jakgieger

  • itinerant farmer
  • ^ SuperNatural Motobricker
  • Posts: 535
Re: 1985 K100 RT It doesn't run...
« Reply #55 on: January 30, 2017, 07:58:56 AM »
did you have to do anything else to make it function correctly? I love speed and power.

I enjoy speed and power as well :bmwsmile .  Since I started with an R60/5,  the K has abundant amounts of both :hehehe .  All you need to do is to restore the bike to it's original functionality!  The injectors were the only "performance" upgrade I did.  If you desire more power, you could do this...
  • Kansas USA
  • 1989 K100rs se
"What we've got here is failure, to communicate.  Some men, you just cain't reach.  So you get what we had here last week.  Which is the way he wants it...Well, he gets it.  I don't like it any more than you men do."

Offline Laitch

  • ^ Quintessential Motobricker
  • Posts: 5208
Re: 1985 K100 RT It doesn't run...
« Reply #56 on: January 30, 2017, 08:19:07 AM »
I enjoy speed and power as well :bmwsmile .
I enjoy the breeze and the Gees.  :riding:
  • Along the Ridley in Vermont.
  • 1995 K75T 68,000 miles
I wept because I had no radials until I met a man who had no splines.

Offline Martin

  • ^ Quintessential Motobricker
  • Posts: 3416
Re: 1985 K100 RT It doesn't run...
« Reply #57 on: January 30, 2017, 04:51:17 PM »
Moonlight walks and puppies.
  • North Lakes Queensland Australia
  • 1992 K75s Hybrid, Lefaux, Vespa V twin.

Offline The Mighty Gryphon

  • ^ Quintessential Motobricker
  • Posts: 3620
Re: 1985 K100 RT It doesn't run...
« Reply #58 on: January 30, 2017, 05:55:32 PM »
Fiber and naps...
  • In my garage in Marilla, NY
  • '94 K75RT Mystic Red, '92K100RS White, '94 K75S Dakar Yellow
Current:
'94 K75RT "Ilsa, She Wolf of the SS"
'94 K75S "Cheetos"
'91 K100RS "Moby Brick Too

Offline Filmcamera

  • ^ Quintessential Motobricker
  • Posts: 1139
Re: 1985 K100 RT It doesn't run...
« Reply #59 on: January 30, 2017, 05:59:26 PM »
Cricket and beer.
  • San Jose, Costa Rica
  • 1991 K100RS 16v ABS1
Poserbricker

Offline Supershooter

  • ^ Proficient Motobricker
  • Posts: 161
Re: 1985 K100 RT It doesn't run...
« Reply #60 on: January 30, 2017, 09:06:33 PM »
Jack the RB racing site was pretty interesting although I didn't find any k100 parts on the price list, which is fine, because I don't need a race bike.


I did bump the injectors with 9V after work, and added some more carb/ injector cleaner.


Dustin
  • Liberty Township, O'brien County, Iowa
  • 85 K100 RT

Offline Supershooter

  • ^ Proficient Motobricker
  • Posts: 161
Re: 1985 K100 RT It doesn't run...
« Reply #61 on: January 31, 2017, 09:19:29 PM »
I contacted Mr Injector, I'm leaning towards sending him my injectors to get them analyzed and flowing correct if they are able.


Thanks for the Mr injector tip!


Supershooter
  • Liberty Township, O'brien County, Iowa
  • 85 K100 RT

Offline mystic red

  • Retired Professsional Driver
  • Forum Moderator
  • ^ Quintessential Motobricker
  • Posts: 2921
Re: 1985 K100 RT It doesn't run...
« Reply #62 on: January 31, 2017, 09:58:20 PM »
Mr. Injector will make them like new if they're salvageable.  :2thumbup:

Offline jakgieger

  • itinerant farmer
  • ^ SuperNatural Motobricker
  • Posts: 535
Re: 1985 K100 RT It doesn't run...
« Reply #63 on: January 31, 2017, 10:59:43 PM »
Dustin, You are welcome to have my old injectors if you need them (24,000 mi and sat with gas in tank for 12+ years :bmwsmile )...I am not going back!  I guess that I also put Magnecor wires on.  Once you get it running, you can do fun things like fan over-ride, aux lights, leds, moly in FD/trn, wire upgrades to protect the starter, etc!!
  • Kansas USA
  • 1989 K100rs se
"What we've got here is failure, to communicate.  Some men, you just cain't reach.  So you get what we had here last week.  Which is the way he wants it...Well, he gets it.  I don't like it any more than you men do."

Offline Elipten

  • ^ SuperNatural Motobricker
  • Posts: 713
Re: 1985 K100 RT It doesn't run...
« Reply #64 on: January 31, 2017, 10:59:47 PM »
Mr Injector is the man!


Sent from my iPad using Tapatalk
  • San Antonio, TX
  • 1990 K75RT

Offline Supershooter

  • ^ Proficient Motobricker
  • Posts: 161
Re: 1985 K100 RT It doesn't run...
« Reply #65 on: February 09, 2017, 10:03:32 PM »
I'm impatiently waiting for my injectors to get sent back. As I continue to think about this project, I wonder if the fuel pressure regulator could be corroded too? If it is van it be serviced?
Supershooter
  • Liberty Township, O'brien County, Iowa
  • 85 K100 RT

Offline Elipten

  • ^ SuperNatural Motobricker
  • Posts: 713
Re: 1985 K100 RT It doesn't run...
« Reply #66 on: February 10, 2017, 12:14:40 AM »
Buy new off Amazon.  Much cheaper than other sources.  I have a post on here somewhere.


Sent from my iPad using Tapatalk
  • San Antonio, TX
  • 1990 K75RT

Offline Supershooter

  • ^ Proficient Motobricker
  • Posts: 161
Re: 1985 K100 RT It doesn't run...
« Reply #67 on: February 10, 2017, 08:08:34 AM »
Can it be serviced or does it just get replaced?
Supershooter
  • Liberty Township, O'brien County, Iowa
  • 85 K100 RT

Offline Elipten

  • ^ SuperNatural Motobricker
  • Posts: 713
1985 K100 RT It doesn't run...
« Reply #68 on: February 10, 2017, 08:09:54 AM »
I guess you could try cleaning.  I just replaced figuring 20 plus years was enough

What do the rest think?


Sent from my iPad using Tapatalk
  • San Antonio, TX
  • 1990 K75RT

Offline Laitch

  • ^ Quintessential Motobricker
  • Posts: 5208
Re: 1985 K100 RT It doesn't run...
« Reply #69 on: February 10, 2017, 08:31:48 AM »
Can it be serviced or does it just get replaced?
If you have replaced the fuel lines and run clean fuel, you'll find out how well it works once you've reassembled and started the engine. Its performance can also be measured with a gauge.

It's a sealed unit so repair is only for the adventuresome, and then only if they can find needed parts. Replace it if you can't tolerate uncertainty.
  • Along the Ridley in Vermont.
  • 1995 K75T 68,000 miles
I wept because I had no radials until I met a man who had no splines.

Offline The Mighty Gryphon

  • ^ Quintessential Motobricker
  • Posts: 3620
Re: 1985 K100 RT It doesn't run...
« Reply #70 on: February 10, 2017, 09:34:45 AM »
+1 on Laitch's advice.

The regulator is nothing more than a can with a spring and a diaphragm in it.  Super simple, but impossible to service.  If you suspect it is bad and are in there already, change it now because it will be a royal pain in the butt to diagnose and replace after everything is put back together.
  • In my garage in Marilla, NY
  • '94 K75RT Mystic Red, '92K100RS White, '94 K75S Dakar Yellow
Current:
'94 K75RT "Ilsa, She Wolf of the SS"
'94 K75S "Cheetos"
'91 K100RS "Moby Brick Too

Offline jakgieger

  • itinerant farmer
  • ^ SuperNatural Motobricker
  • Posts: 535
Re: 1985 K100 RT It doesn't run...
« Reply #71 on: February 10, 2017, 06:10:00 PM »
Dustin,
The pressure regulator was about the only part I did not replace on my fuel system!  Mine has been  working appropriately during the last year...
  • Kansas USA
  • 1989 K100rs se
"What we've got here is failure, to communicate.  Some men, you just cain't reach.  So you get what we had here last week.  Which is the way he wants it...Well, he gets it.  I don't like it any more than you men do."

Offline Supershooter

  • ^ Proficient Motobricker
  • Posts: 161
Re: 1985 K100 RT It doesn't run...
« Reply #72 on: February 11, 2017, 02:28:35 PM »
Jack, I'm going cross my fingers and hope it doesn't need to be replaced at this point.


On a different topic, Bill from Mr injector, emailed me to say that my injectors were stuck, but he was able to get them functioning again. I was excited to get that email! I should have more to do in the shop by next weekend!


Supershooter
  • Liberty Township, O'brien County, Iowa
  • 85 K100 RT

Offline jakgieger

  • itinerant farmer
  • ^ SuperNatural Motobricker
  • Posts: 535
Re: 1985 K100 RT It doesn't run...
« Reply #73 on: February 11, 2017, 06:54:10 PM »
 :2thumbup:
  • Kansas USA
  • 1989 K100rs se
"What we've got here is failure, to communicate.  Some men, you just cain't reach.  So you get what we had here last week.  Which is the way he wants it...Well, he gets it.  I don't like it any more than you men do."

Offline Supershooter

  • ^ Proficient Motobricker
  • Posts: 161
Re: 1985 K100 RT It doesn't run...
« Reply #74 on: February 13, 2017, 08:03:46 PM »
I couldn't take it anymore, while I waited for the injectors to get back, I torn into the rear end and checked and greased the splines.
Injectors should be here any day.


Supershooter
  • Liberty Township, O'brien County, Iowa
  • 85 K100 RT

Tags: