Author Topic: Turn Signal issues, help!  (Read 15475 times)

Offline theblueone

  • Curious
  • Posts: 2
Re: Turn Signal issues, help!
« Reply #25 on: May 14, 2015, 07:41:47 AM »
Hello, I joined specifically for this...

How can you leave me hanging?!?!?  My 1990 k75s  right turn signal acts as four way (do have a four way switch which is acting funny too), horn stopped working also.  Have checked and replaced fuses 3 and 7, back run the starter several times, and still no fix.  Am thinking I'll check all the grounds but 1991k100rs what was your final fix.  I would love to take advantage of your digging to save me some time.

If you're still around I would love to hear what the final fix was (my next step would be the tail cowl ground...then I guess the switches and then the starter.)  Thank you very much.

ps Johnny you crack me up... On Wisconsin!! (Milwaukee/Lancaster/Boulder Junction)
  • western mass
  • 1990 K75S (blue)

Offline K75RT Keith

  • ^ Proficient Motobricker
  • Posts: 439
Re: Turn Signal issues, help!
« Reply #26 on: May 14, 2015, 10:03:12 AM »
Had the same problem a while back .  I cleaned all the grounds.  Pulled and cleaned the starter.   Removed the switch and cleaned with contact cleaner.  Cleaned the switch connections. Pulled the relay and cleaned the connections.  After that my problem ceased to exist.
You can't help someone who doesn't want to hear the answer.

1990 K75RT

Offline theblueone

  • Curious
  • Posts: 2
Re: Turn Signal issues, help!
« Reply #27 on: May 14, 2015, 10:57:03 AM »
That's kind of what I was afraid of.  Thanks for the quick response.  It did sit for about a year while I was tinkering through the final drive.  Time to take it all apart then.  Thanks again.
  • western mass
  • 1990 K75S (blue)

Tags: