Author Topic: Got me a case of the drips. Guessing it's water pump.  (Read 139 times)

Offline JPaganel

  • ^ Proficient Motobricker
  • Posts: 183
Got me a case of the drips. Guessing it's water pump.
« on: August 23, 2019, 04:19:03 PM »
So, I got a blip on the temp light. And when I parked, I saw a drip at the bottom of the water pump. Checked coolant, it's kinda low.

I'm guessing the pump seal is going.

I've been searching threads on that, but a lot of it is dead links. Anyway, doesn't seem like rocket science.

Do I have this right?

Drain coolant and oil
Unscrew pump from motor
Unscrew impeller
Pop out the shaft
Pop put the seals
Pop in new ones
Put it back together and refill.


  • Minnesnowta
  • 1986 K100RT, 1996 R1100RS

Offline mw074

  • ^ Proficient Motobricker
  • Posts: 305
Re: Got me a case of the drips. Guessing it's water pump.
« Reply #1 on: August 23, 2019, 04:37:33 PM »
 That's a bit of an oversimplification. But yes, that's it. Plenty of online videos showing the procedure.
  • Michigan

Offline daveson

  • ^ SuperNatural Motobricker
  • Posts: 480
Re: Got me a case of the drips. Guessing it's water pump.
« Reply #2 on: August 23, 2019, 10:08:26 PM »
That can result from overheating due to a coolant loss from somewhere else. Maybe the radiator cap,  then the overflow level is misleading, especially if the level hasn't been rising after a ride and lowered in the morning. Or there are bubbles after a ride but not a second ride shortly after.
  • Victoria, Australia
  • Current;'86 K100RT Past; '97 Yamaha V Star 650 Yamaha V Star

Tags: