Author Topic: Temperature Warning Light and Cooling Fan Issue 1989 K75 RT  (Read 254 times)

Offline Past-my-Prime

  • Motobrick Curious
  • Posts: 34
Situation: My overtemp warning light comes on even when riding at speed.

Maybe overheating or is this a temperature warning sensor electrical whack light issue; I'm not sure.

I can't figure out if it uses the same sensor to sense temperature and provide a warning light, or is this a separate issue.

Background: the light has been coming on lately when driving even at high speed. The fan works, and the temperature gauge never goes anywhere near the red zone, but the temperature warning light comes on intermittently when the cooling fan is running. The fan will run without the light coming on at times, other times the light comes on at the same time. I'm trying to figure this out. I'm pretty sure this is not how it's supposed to work, but at least now I have a light that tells me my fan is running :)

So I did a coolant flush / refresh yesterday which I posted in "What did I do to my Brick today?" but am starting this as a new thread in order not to be highjacking that thread.

Draining the fluid:



Refilling with 50% concentrated OAT Prestone long life / heavy duty and 50% deionized water:



It took about a gallon altogether. This is more than the book says. Maybe I have the three core radiator as Jo suggested on the other thread but I don't know how to tell.
 
After it was all nicely done, the bike, when warmed up, still gives me the overtemp warning light in tandem with the fan turning on. The temperature gauge, however, never goes much above the middle. Certainly never into the red.

So I thought, maybe the thermostat is stuck. The hoses felt hot both to and from the radiator so maybe was wrong  in retrospect but the radiator itself did not feel hot to touch.

So any fellow RT owner knows, the somewhat laborous removal of various fairing pieces comes next. I'll spare you the photos.

Removal of the thermostat is pretty straightforward.

Measured when cold:

2.5 cm



Measured at 170 degrees:

3.5 cm



So cleaned and put everything back together.



Problem persists.

Assessment: Either my bike is overheating (although the gauge doesn't think so and no overflow that I've seen yet) or the light circuit is somehow connected to the fan on circuit intermittently.

So now I don't know what to trust. Fan runs. Temperature gauge stays in the middle of the range. Temperature warning light comes on at the same time as the fan, sometimes dim, sometimes bright, seems to flicker if I put on additional electrical load such as hand heaters or high beam or even brakes (activating brake light).

Could be an electrical issues, ground maybe, but my god what a mess of wires under the fuel tank. The likelihood of me screwing something up is at least as high as me figuring this out.

Has anyone ever had a similar issue, and is there a straightforward fix?

I am moderately reassured by Frankenduck:

Probably a design or cost issue.   It's really not all THAT important as, just like in a car, the radiator cap will blow before engine damage is done.

The other way would be to pull the back of the instrument cluster off and test the bulb.

Since it never goes on the chances are very high that it's as good as a brand new bulb.


Then I see this post from Martin . . makes me think that whatever tells the bulb to come on is cutting in early but that might be just wishful thinking.

Liverpool Thermostat starts to open 186 F, Fan cuts in 217F, Warning light , activates 232F.
Regards Martin.

Recommendations?
My next plan with this is to run the bike see when the light comes on, and tape a temperature probe to the hottest part of the cooling system and see what the coolant temperature is at that point. Does that make sense? I am reluctant to get into the spaghetti of wires under the tank if I can at all avoid it.
  • North Shore of Lake Superior
  • 1989 K75 RT

Offline The Mighty Gryphon

  • ^ Quintessential Motobricker
  • Posts: 4541
Re: Temperature Warning Light and Cooling Fan Issue 1989 K75 RT
« Reply #1 on: July 21, 2019, 01:20:16 PM »
When you did your radiator flush, did you run a system cleaner with distilled water to descale the minerals in the system?  If any of the previous owners used well water in the system it can be full of scale.  Heck even city water in some places can be pretty hard as well.  I had to do one engine and radiator twice to get all the hard water crap out.

Also, how do the spaces between the fins of the radiator look?  I would imagine that in your part of the world there could be a pretty heavy load of small flying life forms blocking the airflow.  I had to remove and soak my radiator overnight in vinegar to remove the bugs that were making my bike overheat.

I wouldn't worry about temperature gauge readings vs. fan operation.  I have noticed that the gauges often read "low", probably because of poor electrical conductivity between the sensor and the engine as well as in the electrical connections in the harness that are getting on to 30+ years old.
  • In my garage in Marilla, NY
  • '94 K75RT Mystic Red, '91K100RS White/Blue
Current:
'94 K75RT "Ilsa, She Wolf of the SS"
'91 K100RS "Moby Brick Too

Offline Laitch

  • ^ Quintessential Motobricker
  • Posts: 6737
Re: Temperature Warning Light and Cooling Fan Issue 1989 K75 RT
« Reply #2 on: July 21, 2019, 02:17:22 PM »
Situation: My overtemp warning light comes on even when riding at speed.

So I did a coolant flush / refresh yesterday which I posted in "What did I do to my Brick today?" but am starting this as a new thread in order not to be highjacking that thread.

You can't hijack your own thread; you can only create confusion in it. :giggles 

In my moto, I want the coolant system and its warning system functioning as designed rather than be warned by overheated coolant spraying on me during a failure so I wouldn't be reassured by the status quo of your system.

The thermostat seems to be opening early but also seems to be working according to design. What is unknown is whether the coolant impeller is actually moving coolant through the radiator when the t-stat is open, or just barely moving on the end of its spinning shaft because its fastener has become loose. Did you squeeze the radiator hose to eliminate air from the coolant as part of the renewal process?

Consider doing a pressure test of the radiator cap or at least inspecting its gaskets for drying or debris. Intermittent pressure loss will cause overheating and  coolant loss.

The dash temperature gauge is operated by a sensor plug screwed into the combo pump. The warning light and fan are operated by the temperature switch in the relay box. Those are separate systems. As Gryph has indicated, the dash gauges apparently can be fickle in reporting.

Information on radiator types can be seen in this thread.


  • Along the Ridley in Vermont.
  • 1995 K75T 72,000 miles
I wept because I had no radials until I met a man who had no splines.
http://www.motobrick.com/index.php/topic,296.msg53303.html#msg53303

Offline johnny

  • TrailBrakingThrottleWhacker
  • ^ Quintessential Motobricker
  • Posts: 6669
  • Whacking...n...Chopping Sliding...n...High Siding
Re: Temperature Warning Light and Cooling Fan Issue 1989 K75 RT
« Reply #3 on: July 21, 2019, 04:26:31 PM »
greetings...

take a photo of your cluster when this light you speak of is on and take a photo of your gauge simotanously and poast them here...

j o
  • :johnny i parks my 96 eleven hundert rs motobrick in dodge county cheezconsin  :johnny

Offline Martin

  • ^ Quintessential Motobricker
  • Posts: 3805
Re: Temperature Warning Light and Cooling Fan Issue 1989 K75 RT
« Reply #4 on: July 21, 2019, 06:23:17 PM »
A laser temperature gun can be had pretty cheaply these days Ebay, Aliexpress or Harbour Freight. They are a very useful diagnostic tool for diagnosing all sorts of problems. I use mine on the cooling system, the fuel system and on the header pipes to see if one cylinder is running cooler than the others. I also use it to compare one bike with another. Buying one will definitely help in running down your problem.
Regards Martin.
  • North Lakes Queensland Australia
  • 1992 K75s Hybrid, Lefaux, Vespa V twin.

Offline Past-my-Prime

  • Motobrick Curious
  • Posts: 34
Re: Temperature Warning Light and Cooling Fan Issue 1989 K75 RT
« Reply #5 on: July 22, 2019, 09:40:22 PM »
greetings...

take a photo of your cluster when this light you speak of is on and take a photo of your gauge simotanously and poast them here...

j o

After my drive to work: I'm in the garage, high beams are ON, engine running, fan running, temp. gauge N, overtemp light on:



Turn high beams off, magically, the fan turns off, and the engine is running cooler!?!:



Just checking: turn on high beams again, over temp light comes back on along with the cooling fan:



.

.

.

This is AFTER a full coolant flush with coolant flush stuff from Prestone and mixed with dionized water. I couldn't find distilled water but since then I've read TMG's post somewhere about dehumidifiers which we have running constantly except it's draining into the sump so I have to disconnect the hose if I want to fill the reservoir and use that water. Anyway, flushed and not much crud came out at all which makes sense because I AM the PO and therefore have no one to blame but myself for everything.

Anywho where was I?  So after taking those photos I went to my office and did my work that lets me pay for all this stuff and after that I want for 100 mile ride to the border where I picked up my Iconic 22 liter case (I'll post about that elsewhere to avoid highjacking my own thread) and initiallly had lost of red light of overheat warning brought on by any electrical use like high beams or blinkers or brake lights but seemed much better by the end of the run.

Then I went and had a bunch of beers and got my son to drive me home and now here I am posting.

Maybe the problem FIXED ITSELF!

Does this help?
  • North Shore of Lake Superior
  • 1989 K75 RT

Offline Laitch

  • ^ Quintessential Motobricker
  • Posts: 6737
Re: Temperature Warning Light and Cooling Fan Issue 1989 K75 RT
« Reply #6 on: July 22, 2019, 10:19:07 PM »
Does this help?
Yeah. Clean the starter. :giggles  In the meantime, try backspinning the starter if that combo occurs again.
 [ Invalid Attachment ]
  • Along the Ridley in Vermont.
  • 1995 K75T 72,000 miles
I wept because I had no radials until I met a man who had no splines.
http://www.motobrick.com/index.php/topic,296.msg53303.html#msg53303

Offline The Mighty Gryphon

  • ^ Quintessential Motobricker
  • Posts: 4541
Re: Temperature Warning Light and Cooling Fan Issue 1989 K75 RT
« Reply #7 on: July 22, 2019, 11:27:45 PM »
Does the high temperature light and the fan come on SIMULTANEOUSLY with the high beam?  Or does it take a minute or so?

If it is simultaneous, I would check the voltage between the engine block and the negative battery terminal when the fan is running.  I suspect that you may have a bad ground connection somewhere, possibly in the starter that is causing some whack when the extra current of the high beam is put through it.  If indeed there is a bad ground you might want to go and check the engine ground on the side of the transmission and the frame ground under the tank.
  • In my garage in Marilla, NY
  • '94 K75RT Mystic Red, '91K100RS White/Blue
Current:
'94 K75RT "Ilsa, She Wolf of the SS"
'91 K100RS "Moby Brick Too

Offline Past-my-Prime

  • Motobrick Curious
  • Posts: 34
Re: Temperature Warning Light and Cooling Fan Issue 1989 K75 RT
« Reply #8 on: July 23, 2019, 09:49:20 PM »
The fan and the warning light would come on simultaneously with the high beams. Or the blinkers, it would cycle on and off with them. Or the brake light.

I'd like to clean up my starter but I'm too scared to try to drive my bike backwards!!

Anyway, I decided to take it for a work-related trip today and over 500 km, the over temp light did not come on at all. The fan came on once in a while when I had to stop at a construction zone, and at the end when I was putting it into the garage.

I agree it's probably a shared ground that needs to be cleaned. (not certain if it's the frame ground or under the fuel tank or within the starter, and I'll start with the frame grounds.)

But like many things, the bike likes to be ridden. And I'm not able to replicate the problem any more. I suspect the electrons found their way!

  • North Shore of Lake Superior
  • 1989 K75 RT

Tags: