Author Topic: UK New guy :D  (Read 275 times)

Offline slparry

  • Curious
  • Posts: 1
UK New guy :D
« on: July 06, 2019, 02:45:26 AM »
Recently bought a K1 having had 5 K100RS's in the past and loving it!

I was off on Monday so me and a mate put the bike up on the ramp and spent the day servicing it and generally fettling.

First task was the speedo wasn't working, the previous owner have cracked the tacho lens so water had got in. Upon removing I was shocked when dismantling the console to find the speedo pcb sat in a half inch of water.... I'd got a good speedo off ebay from a K100RS 16v. It's obviously got the wrong mileage on it but they're easy to adjust and at some point will dismantle it and correct the mileage, whilst in there I'll swap the clock facias and needles as the RS ones are white and the K1's are yellow. Sure I could just leave it but it may as well be "right" :D

Any upshot is the speedo is now working!

Spent ages trying to find the ABS diagnostic plug. It's in a different location to the previous RS's I'd had. Anyway once found did some diagnostics with the multimeter, counting the needle swings, which indicated it was only needing reset because of the battery having gone bad previously …. so with fingers crossed performed the ABS reset. Sometimes you have to repeat the reset because it's an old system and can only deal with one request at a time so if there's a couple of faults stored they have to be cleared individually. Plus you don't know if it's "reset" until you ride it. However, I was hopeful after I saw the meter sit as a constant voltage and not swinging from 0 to + volts.

Went to pull the bike backwards onto the drive with the intention of riding up the drive to hopefully get enough speed to get the ABS lights to turn off but even pulling it backwards was fast enough for the sensors to trigger and WAHAY the abs light went out.... subsequent stamping on the rear brake whilst out on a ride confirms the ABS is now functioning :D

Then we did the service, Mobil 1 15w50 Racing Motorcycle oil, OEM filter, new NGK spark plugs (for some reason it had DPR7EA's in (which are projected resistor plugs) OEM spec in NGK is D7EA's but I've always run my K's on slightly colder D8EA's given I work my bikes quite hard (throwback to my 2 stroke days). Anyway a set of D8EA's in, then set the injector body balance and tickover (set at the lower end of 900rpm because I like lower tickover…. factory spec is 900 to 1000 rpm)

The whole thing is now smoother and quicker. There was a flat spot at 4000 rpm which has gone :)

Next week I'll change the gearbox and final drive oils with some 80w90 Mobil 1 synthetic, makes the gearboxes nice and slick on older K's.

I'll also hunt out my CO meter and test the CO levels are within spec.

Only thing not working now is the gear position indicator and the neutral light. I've ordered a new switch but will probably not bother doing the job until some time in the future. At present it's showing 4 when in 1st, 5 when in neutral, blank in 2nd, blank in 3rd, then real 4th and 5th it shows correctly.

The reason for the hesitancy in replacing the switch is that it's at the rear of the gearbox and you have to remove the swingarm to get to it, plus its screws can be seized in so doing it is not to be taken lightly. Given it will often crumble when you start messing with an old one I'll put it on the "job to do if I'm there doing something else" list :D

But it's pretty much now all working, cruises lovely at 80 to 90 and is only just getting into its stride at three figures :D

  • Gwynfryn
  • 1993 BMW K1, 2015 R1200RT LE, 2014 F800GS, 1986 R80RS
Agree Agree x 1 View List

Offline natalena

  • ^ Proficient Motobricker
  • Posts: 402
Re: UK New guy :D
« Reply #1 on: July 06, 2019, 03:09:34 PM »
Congrats on the new-to-you brick, and having Mates that will give a hand. Some pics would be awesome, and Motobins is your friend.
  • East of Joshua Tree
  • 1987 K75s #0919
On Holy Quest seeking Techron equivalent for splines.
Agree Agree x 1 View List

Offline Soggz

  • ^ SuperNatural Motobricker
  • Posts: 636
  • 2 wheels are better than 4,but 4 wheels,2 bikes...
Re: UK New guy :D
« Reply #2 on: July 08, 2019, 05:23:46 PM »
Hi,from deepest,darkest Somerset!
  • Down in Selwood Forest
  • 1986 K75C, 1982 Honda CX500EC Eurostreetbrat
One More Of These,One Less Of Those...

Offline DJEwen

  • ^ Proficient Motobricker
  • Posts: 348
Re: UK New guy :D
« Reply #3 on: July 09, 2019, 08:46:48 AM »
Hello from Scotland.
  • Scotland
  • 1985 K100 'Revive', 1987 K100 LT

Tags: