Author Topic: Koso and Maru 3.0 problem  (Read 339 times)

Offline Max

  • Motobrick Curious
  • Posts: 27
Koso and Maru 3.0 problem
« on: January 19, 2019, 12:00:47 PM »
Hi all, i am in the process of wiring up the koso dl03 to the Maru bep 3.0 and have hit a problem. The bike starts and runs sweet, speedo registers voltage although it's below 12v on idle and 13-14 under load so guess this is right. It's the eobd light that won't go out, the purple wire from the koso is in the Wrn on the bep 3.0  and I guess this is right, there is a little opening next to the Wrn pin on the bep and not sure what that is. Does any one have a diagram of connecting a koso to the bep?. Cheers
  • Uk
  • K100rs

Offline rbm

  • ^ Quintessential Motobricker
  • Posts: 1896
Re: Koso and Maru 3.0 problem
« Reply #1 on: January 19, 2019, 01:46:25 PM »
WRN is an aggregated output from the BEP 3.0, meaning that it combines several possible warning sensors into one indicator using diodes.  This means that if any one or more of the sensors triggers, the indicator will light up. Then you have to figure out which sensor or sensors tripped and fix it/them.

The sensors WRN aggregates are brake lamp test (BMU), ABS, Alternator charge light, Water temperature, Oil pressure, and Choke.  So, the question is whether you've gone through to diagnose all of these sensors (except ABS since you have an 1985 K100).
  • Regards, Robert
Toronto, Ontario

1987 K75 - Build Blog @http://k75retro.blogspot.ca/

Offline Laitch

  • ^ Quintessential Motobricker
  • Posts: 6206
Re: Koso and Maru 3.0 problem
« Reply #2 on: January 19, 2019, 01:55:37 PM »
The sensors WRN aggregates are brake lamp test (BMU), ABS, Alternator charge light, Water temperature, Oil pressure, and Choke. 
That is the Imperial Idiot Wizard of warning lights!
  • Along the Ridley in Vermont.
  • 1995 K75T 68,000 miles
I wept because I had no radials until I met a man who had no splines.
http://www.motobrick.com/index.php/topic,296.msg53303.html#msg53303

Offline Max

  • Motobrick Curious
  • Posts: 27
Re: Koso and Maru 3.0 problem
« Reply #3 on: January 19, 2019, 02:33:49 PM »
Sorted it. The purple wire from the koso goes to the bulb test, not Wrn as this is not a multi function set up. The bike also needs a bulb style rear light and not led as the resistance is to low to register. Thank you for the advice any way.
  • Uk
  • K100rs

Offline Max

  • Motobrick Curious
  • Posts: 27
Re: Koso and Maru 3.0 problem
« Reply #4 on: January 19, 2019, 02:39:36 PM »
As an addition, with the standard console plugged in there are no warning lights on other than oil and battery after the brakes have been pressed. The eobd light only stayed on with the koso purple wire in the wrn which I believe my bike does not have because there are individual lights for each fault.
  • Uk
  • K100rs

Offline Laitch

  • ^ Quintessential Motobricker
  • Posts: 6206
Re: Koso and Maru 3.0 problem
« Reply #5 on: January 19, 2019, 02:59:55 PM »
Sorted it. The purple wire from the koso goes to the bulb test, not Wrn as this is not a multi function set up.
:clap:
  • Along the Ridley in Vermont.
  • 1995 K75T 68,000 miles
I wept because I had no radials until I met a man who had no splines.
http://www.motobrick.com/index.php/topic,296.msg53303.html#msg53303

Tags: k100