Author Topic: Stalls when warm on a run - won't idle  (Read 213 times)

Offline bluebossa

  • ^ Proficient Motobricker
  • Posts: 116
  • K75 and R65 Owner
Stalls when warm on a run - won't idle
« on: September 16, 2018, 01:21:17 PM »
Been tweaking and test riding my fresh re-build - it's running pretty well after a full Engine swop and re-build, but once warm and on a run won't settle to idle when coming to a stop for junctions, lights etc. Researched the forum and done a few things already.. need to check Z pipe for cracks I think...

So far I've:

Adjusted and Cleaned Plugs
Adjusted Throttle Position Sensor - 0 at off and clicks, working fine
Adjusted Slow Running and Fast Running when Hot
Timing adjusted - in line with advice on here +3 degrees, pulls well
Throttle bodies synched up with Carb gauges
All connections, earths, connectors clean and greased

Starts straight after it's stalled  but needs revs to keep it going on a run- seems fine cold?

Pulls like a train up to 75 mph - will sit idling fine oncee started and back in the garage - just stalls after the overun and coming to a stop.
So is it something to do with the Airflow meter when moving perhaps?

Any ideas - thanks...
  • UK
  • K75 RT
Current Bikes: K75 in the UK, R65 back in UK
Former Bikes:  R850R, K1100RS, Dnepr MT10-36
K569 (K 75, K 75 c, K 75 s, K 75 RT) BMW K 75 RT (0565,0573). Type Code: 0565

Offline The Mighty Gryphon

  • ^ Quintessential Motobricker
  • Posts: 3764
Re: Stalls when warm on a run - won't idle
« Reply #1 on: September 16, 2018, 01:49:08 PM »
My 1992 K100RS 16V did the same thing.  I never was able to find what the problem was.  The last thing I tried was a new voltage regulator.  Sold it shortly thereafter so no history of whether it helped.  My theory was that the voltage was dropping off and killing the ECU output to the injectors.
  • In my garage in Marilla, NY
  • '94 K75RT Mystic Red, '92K100RS White, '94 K75S Dakar Yellow
Current:
'94 K75RT "Ilsa, She Wolf of the SS"
'94 K75S "Cheetos"
'91 K100RS "Moby Brick Too

Offline bluebossa

  • ^ Proficient Motobricker
  • Posts: 116
  • K75 and R65 Owner
Re: Stalls when warm on a run - won't idle
« Reply #2 on: September 16, 2018, 01:58:09 PM »
My 1992 K100RS 16V did the same thing.  I never was able to find what the problem was.  The last thing I tried was a new voltage regulator.  Sold it shortly thereafter so no history of whether it helped.  My theory was that the voltage was dropping off and killing the ECU output to the injectors.

Quite a few people experienced similar - reading though forum.

I've just checked Z pipe and looks in good condition... it's annoying as first ride on it today was siblime - motorway speeds, bumbling along country lanes, but once warm just kept stalling... makes for a tricky ride...

Everything is 100% tight and clean too... been through every nut, bolt, rubber and connection.
  • UK
  • K75 RT
Current Bikes: K75 in the UK, R65 back in UK
Former Bikes:  R850R, K1100RS, Dnepr MT10-36
K569 (K 75, K 75 c, K 75 s, K 75 RT) BMW K 75 RT (0565,0573). Type Code: 0565

Offline Chaos

  • ^ Quintessential Motobricker
  • Posts: 2133
  • Mars needs women!
Re: Stalls when warm on a run - won't idle
« Reply #3 on: September 16, 2018, 02:18:14 PM »
Have you checked the Hall Effect Sensor, you can do it with a hair dryer.  The tend to act up when hot.
  • sw ohio
1987 K75S    VIN 0231
Original owner, Original litter
200,000 miles (plus or minus) and 5 paint jobs
2012 Ural 2WD sidecar (BMW's bastard step child)

Offline bluebossa

  • ^ Proficient Motobricker
  • Posts: 116
  • K75 and R65 Owner
Re: Stalls when warm on a run - won't idle
« Reply #4 on: September 16, 2018, 05:09:41 PM »
Have you checked the Hall Effect Sensor, you can do it with a hair dryer.  The tend to act up when hot.

No, but I've got a spare HES off original Engine, so maybe swop over at the weekend.

I've just had all the Airscrews out and cleaned and reset them.
Starts perfect - and seems great when cold - tiny bit reluctant to get up above 1000 revs at first quarter turn. Ticks over lovely though.

Thanks for tip... will report
  • UK
  • K75 RT
Current Bikes: K75 in the UK, R65 back in UK
Former Bikes:  R850R, K1100RS, Dnepr MT10-36
K569 (K 75, K 75 c, K 75 s, K 75 RT) BMW K 75 RT (0565,0573). Type Code: 0565

Offline Supershooter

  • ^ Proficient Motobricker
  • Posts: 172
Re: Stalls when warm on a run - won't idle
« Reply #5 on: September 16, 2018, 10:41:40 PM »
I may be having the same or even a different issue. Starts fine, go for a ride come to a stop sign and the it doesn't wN to get going again, so I'll be watching.

Supershooter
  • Liberty Township, O'brien County, Iowa
  • 85 K100 RT

Offline bluebossa

  • ^ Proficient Motobricker
  • Posts: 116
  • K75 and R65 Owner
Re: Stalls when warm on a run - won't idle
« Reply #6 on: September 21, 2018, 08:17:08 AM »
Ordered and received a Z Pipe - otherwise known as Crankcase Breather pipe... 10

Took the old one off, fitted and inspected it and though it looked OK when unstressed you can see cracks when it's moved...
While I can't seem to make it leak from my own lungs - who knows, this seems to affect pretty much all K75s and is a weakspot from what I have read.

Started Bike and did seem to idle solidly without any hunting so hope that's the cure - will report once I've been out on it...
Picture attached for reference
  • UK
  • K75 RT
Current Bikes: K75 in the UK, R65 back in UK
Former Bikes:  R850R, K1100RS, Dnepr MT10-36
K569 (K 75, K 75 c, K 75 s, K 75 RT) BMW K 75 RT (0565,0573). Type Code: 0565

Offline Laitch

  • ^ Quintessential Motobricker
  • Posts: 5418
Re: Stalls when warm on a run - won't idle
« Reply #7 on: September 21, 2018, 09:38:18 AM »
Took the old one off, fitted and inspected it and though it looked OK when unstressed you can see cracks when it's moved...
While I can't seem to make it leak from my own lungs - who knows, this seems to affect pretty much all K75s and is a weakspot from what I have read.
How did you hook your lungs up to it?
  • Along the Ridley in Vermont.
  • 1995 K75T 68,000 miles
I wept because I had no radials until I met a man who had no splines.

Offline bluebossa

  • ^ Proficient Motobricker
  • Posts: 116
  • K75 and R65 Owner
Re: Stalls when warm on a run - won't idle
« Reply #8 on: September 21, 2018, 10:59:37 AM »
How did you hook your lungs up to it?

Through the hole at the front of my face :-)

I've just been out and sprayed Carb cleaner down near TB 1 and it's base where it hits the Head - Idle went way down and even stalled so bugger, must be a leak or a poor seal on the TB Rubber.

Is it a case of just getting a new one or can they be taken off and some Gasket Sealer or similar be smeared between it and head to cure leak?
Any tips - or is it just that the rubber hardens and they need replacing?

This part is 30 each new...

  • UK
  • K75 RT
Current Bikes: K75 in the UK, R65 back in UK
Former Bikes:  R850R, K1100RS, Dnepr MT10-36
K569 (K 75, K 75 c, K 75 s, K 75 RT) BMW K 75 RT (0565,0573). Type Code: 0565

Offline bluebossa

  • ^ Proficient Motobricker
  • Posts: 116
  • K75 and R65 Owner
Re: Stalls when warm on a run - won't idle
« Reply #9 on: September 21, 2018, 03:07:35 PM »
Answered my own question, took TBs off, ironed out a couple of nodules, then gasket sealed and refitted.

No leaks, a run awaits
  • UK
  • K75 RT
Current Bikes: K75 in the UK, R65 back in UK
Former Bikes:  R850R, K1100RS, Dnepr MT10-36
K569 (K 75, K 75 c, K 75 s, K 75 RT) BMW K 75 RT (0565,0573). Type Code: 0565

Offline bluebossa

  • ^ Proficient Motobricker
  • Posts: 116
  • K75 and R65 Owner
Re: Stalls when warm on a run - won't idle
« Reply #10 on: September 22, 2018, 10:02:29 AM »
Test rode it this morning and definitely improving but still not 100% - stalled a couple of times, though a lot less...

I took the plugs out and while 1 and 2 are nice and brown, 3 looked wet/fuelly - pics of 2 and 3 attached.
Cleaned, re-gapped and swopped out Plug 3 for a known good one.. any ideas

Couple of Videos uploading to YouTube of running and stalling for any pointers - thanks in advance...
  • UK
  • K75 RT
Current Bikes: K75 in the UK, R65 back in UK
Former Bikes:  R850R, K1100RS, Dnepr MT10-36
K569 (K 75, K 75 c, K 75 s, K 75 RT) BMW K 75 RT (0565,0573). Type Code: 0565

Tags: